Jump to content

Code 30000 is getting on my nerves.


Recommended Posts

So I recently bought Star Citizen to play with some friends and have fun. I downloaded it and started it up. It takes forever to get from the launch menu to the enter star citizen menu. I have never been able to even get into the game and I have launched the game over 20 times in the past 3 days. Everytime I try to get into the game it loads then freeze then says error code 30000. I have tried everything that has been recommended to me. I have deleted the character file inside the star citizen files. I have reinstalled the game itself. I have changed my WiFi ports. I have logged out and logged back in. I have repaired my account. I’ve deleted everything and started fresh. But no matter what I do I cannot get in I always get code 30000. I have never passed the loading screen within the 3 days and 20 times I have tried to launched and tried to play the game. So I am at a loss and I don’t know what to do. I did speed test to check my internet connection and it said I have good speed or “fast speed” so it’s not an internet issue. I have a Nvidia GeForce RTX 3060 12gb graphics card and a Ryzen 5 5600 6 core cpu with 16gb ram.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...