Jump to content

Can't launch Star Citizen anymore. Does really nobody else have this problem...?


Recommended Posts

I used to play SC with no problems so far; having downloaded the latest 3.11 patch though, SC (the game) simply won't launch any more. The launcher itself (1.4.4) starts just fine, logs in just fine, but as soon as I click on "launch game" I _instantly_ get a "SC has stopped running unexpectedly" red dialog, no matter how many times I try, or how many times I attempt "verify". This is clearly not a network / CIG servers related issue, as it happens _far_ too fast - there's something in the new patch crashing, but "verify" does nothing to help. That would suggest though that I shouldn't be the only person seeing this happen - anyone...? anyone...? Bueller...?

Link to post
Share on other sites

It seems that you are not alone with this problem : 

https://robertsspaceindustries.com/community/issue-council/star-citizen-alpha-3/STARC-129359-Star_citizen_has_stopped_running_unexpectedly_-_instant_crash_when_clicking_launch_game_from_launcher__no_crash_log_generated

 

A guy is saying that a driver update could solve the issue :
 

Quote

I have only just gotten around to trying the PTU this session and ran into this error. the LIVE build worked for me previously. As per my specs, Im running windows 7 professional 64 bit, with an i7-6700 processor EDIT: I managed to fix it by updating my graphics drivers, if anyone else has an AVX compatible processor and has this issue it might be your drivers don't have/out of date Vulkan in them (mine were from early 2017 when I built this pc)

 

 

Link to post
Share on other sites

Hopefully you aren't trying to play on an old PC...

Quote

We wanted to give you a heads up that we'll be updating our minimum system requirements with the update coming to the RSI Launcher tomorrow. Specifically, AVX (Advanced Vector Extensions) CPU technology will be a requirement going forward. It's important to note that only older CPUs don't utilize this technology, and we expect very few of you to be impacted by this change.

AVX technology was introduced with Intel's Sandy Bridge processor and AMD's Bulldozer processor (both released in 2011). This means that processors that pre-date this will no longer be able to effectively launch Star Citizen from the updated launcher.

Source

Link to post
Share on other sites

I'm about as much of a pacifist as one can get, but right now I'd just like ten minutes with a chainsaw in a room alone with the guy with "we expect very few of you to be impacted". Just ten minutes! Please?!? It's totally fair, considering they are FORCING me to spend thousands of euros on a new PC, for absolutely just one single app, in a year I can't afford that, basically on a shitty whim. If all these years SC could run fine without "AVX" I'm absolutely sure it could have done so for many more years to come, especially seeing as how nobody at CIG gives half a rat's dick about making things running faster "because alpha". This is just about the shittiest time to suddenly and arbitrarily  up one's hardware requirements for absolutely no good reason whatsoever.

Anyway, thanks for the video driver tip, I'll try it, maybe it does something useful, but I doubt it - I don't completely replace my PC every few years for no reason whatsoever, so while it could run SC quite ok, it's quite likely it doesn't have this newfangled fancy shit which means CIG just locked me the fuck out of a few hundred euros worth of horribly buggy alternate reality I (used to) use to escape from my even more unbearably shitty real life...

Link to post
Share on other sites

...also, I'd really like to know which unpaid intern coded the retarded launcher that just silently crashes the game executable instead of actually putting up a "hahaha, thanks for all your cash and fuck you very much Citizen, you're out!" dialog...

Link to post
Share on other sites
On 10/9/2020 at 3:53 PM, Porcupine said:

I used to play SC with no problems so far; having downloaded the latest 3.11 patch though, SC (the game) simply won't launch any more. The launcher itself (1.4.4) starts just fine, logs in just fine, but as soon as I click on "launch game" I _instantly_ get a "SC has stopped running unexpectedly" red dialog, no matter how many times I try, or how many times I attempt "verify". This is clearly not a network / CIG servers related issue, as it happens _far_ too fast - there's something in the new patch crashing, but "verify" does nothing to help. That would suggest though that I shouldn't be the only person seeing this happen - anyone...? anyone...? Bueller...?

Haven't tried in a while, my 2080 didn't handle it well.  Waiting until October 28th for my 3080 to show up and give it another shot.

Link to post
Share on other sites
4 hours ago, Gallitin said:

Haven't tried in a while, my 2080 didn't handle it well.  Waiting until October 28th for my 3080 to show up and give it another shot.

Make sure you've got it on a good SSD, too. I'm running a 2080ti, i7-9700k rig and had no issues aside from some frame drops.

Link to post
Share on other sites

Well, it wasn't the video drivers. I mean those too, because trying to launch the SC executable directly, sans launcher, no longer mentions something about a vulcan dll entry point when it dies. Now it just dies. Guess this is the AVX part.  Guess it's also the part where I've just had my Citizenship revoked. I'll go get my hat now. For shame, CIG, for shame...

Link to post
Share on other sites

Well it sucks but at least you have plenty of time to figure out a solution before the real game is ready. I do have a PC that now can't run it, but I haven't used that PC for actual gaming since World of Warcraft was fresh.

And actually I have to congratulate you in that you've avoided buying a lot of Intel CPU "upgrades" with very little actual improvement (other than the big improvement leap to Sandy Bridge). A modern CPU now should last you another 10+ years.

Link to post
Share on other sites

@Porcupine

I wouldn't worry too much. I'm basically in the same situation with my creaky old rig. The difference being that I can actually get the thing to load.......... BUT............

I've now given this crapola 4 attempts with the following results all trying to do a bog standard box mission i.e. nothing fancy.

1st attempt (best), I actually managed to collect all three boxes. I delivered 1 and then game completely froze solid. I gave it plenty of time to unfreeze itself then had no alternative but ctrl alt del.

2nd attempt, same again but without being able to deliver a single box.

3rd attempt, 30k before I actually got to my ship. It did let me file a claim though {destroyed ship resulting from attempt 2).

4th attempt, 30k just as I was about to take off from Microtech.

See you all in patch 12 or 11.whatever for very likely more of the same.

Ah well, back to MS Flight Sim 2020. The aircraft nav systems might be pretty screwed but at least you can play the thing.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By ThunderChilde
      5 attempts, 3 verifies, all shut down in task manager. Finally got a package and this is what I am staring at. Hints, Tips, Useless comments welcome.
    • By Pockets
      I am unable to launch this game, all I get is 'STAR CITIZEN HAS STOPPED RUNNING UNEXPECTIDLY'   written in red, it gives me the option to relaunch that does nothing, or verify that seems to check stuff but then does nothing same problem. I searched the net, i reinsalled several times, I deleted the BIN folder and revarified (didn't work), I allowed exception on my windows antivirus/firewall (didn't work), I looked up about windows N,  windows wouldn't allow me to install the windows media pack but star citizen info says if i have windows 10 home i don't need it anyway, I just can't get this thing to launch at all, has anyone else had this problem and if so how did they fix it?
    • By Pockets
      I have been looking at the various videos, adverts, the star citizen site ect and everything seems to say mmo player, but when I try to down load the game it says single player. I keep thinking I am going to be paying all this money for a game that isn't suited to my play. So i figured I'd just go for it and ask people that know. Is this game a multi player game, like eve-online where you can be together it alliances and community and fly together and cooperate to develop or is this a single player game where you just play sims and shoot npc? Do you get to shoot other players and battle, and walk around with other players like in wow or is it purely single player like sims4 with spaceships so to speak?
    • By viperalpha
      I am building my SC beast. I am using a Lian Le dynamic XL case. The case itself has several  USB3.2 recepticles which breales down into two leads and I only have 1  3.2 header on my MB  What do I need to get to  hook all of the leads up?  See the pictures


    • By Dabclipers
      I realize that likely nobody knows the exact time it's going live, but I was wondering when everyone thinks we can expect 3.3 to hit the servers?  I was under the impression it was supposed to be available yesterday.
×
×
  • Create New...